<!doctype html>
<html xml:lang="en-US" lang="en-US" >
<head>
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
	    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton | mediamag blog</title><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="mediamag blog &raquo; Feed" href="http://mediamag.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="mediamag blog &raquo; Comments Feed" href="http://mediamag.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="mediamag blog &raquo; Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton Comments Feed" href="http://bit.ly/2kIM8Kz/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/mediamag.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='rok_widget_grid_css-css'  href='http://mediamag.ca/wp-content/plugins/wp_rokgallery/templates/widget/grid/grid.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='rok_widget_style_css-css'  href='http://mediamag.ca/wp-content/plugins/wp_rokgallery/templates/widget/grid/light/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='juiz_sps_styles-css'  href='http://mediamag.ca/wp-content/plugins/juiz-social-post-sharer/css/juiz-social-post-sharer-5.min.css?ver=1.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://mediamag.ca/wp-content/plugins/social-media-widget/social_widget.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://mediamag.ca/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='grid-responsive786-css'  href='http://mediamag.ca/wp-content/plugins/gantry/css/grid-responsive.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='grid-responsive541-css'  href='http://mediamag.ca/wp-content/themes/rt_cerulean_wp/css/grid-responsive.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap838-css'  href='http://mediamag.ca/wp-content/themes/rt_cerulean_wp/css-compiled/bootstrap.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='master-e165630418b3e13f957bd74b82ca67f0902-css'  href='http://mediamag.ca/wp-content/themes/rt_cerulean_wp/css-compiled/master-e165630418b3e13f957bd74b82ca67f0.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='mediaqueries27-css'  href='http://mediamag.ca/wp-content/themes/rt_cerulean_wp/css-compiled/mediaqueries.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='style879-css'  href='http://mediamag.ca/wp-content/themes/rt_cerulean_wp/style.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://mediamag.ca/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://mediamag.ca/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.4 - Universal enabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-20534248-3', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://mediamag.ca/wp-content/plugins/wp_rokgallery/assets/js/mootools.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://mediamag.ca/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://mediamag.ca/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://mediamag.ca/wp-content/plugins/bitly/js/bitly-client.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://mediamag.ca/wp-content/themes/rt_cerulean_wp/js/rokmediaqueries.js?ver=4.1.11'></script>
<link rel='https://api.w.org/' href='http://mediamag.ca/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://mediamag.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://mediamag.ca/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Edmonton&#8217;s About to Enjoy a New Locally Produced Magazine' href='http://bit.ly/2juJCHk' />
<meta name="generator" content="WordPress 4.7.2" />
<link rel="canonical" href="http://bit.ly/2kIM8Kz" />
<link rel='shortlink' href='http://mediamag.ca/?p=12055' />
<link rel="alternate" type="application/json+oembed" href="http://mediamag.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbit.ly%2F2kIM8Kz" />
<link rel="alternate" type="text/xml+oembed" href="http://mediamag.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbit.ly%2F2kIM8Kz&#038;format=xml" />
<link rel='shortcut icon' href='http://mediamag.ca/favicon.ico' />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton" />
<meta property="og:url" content="http://bit.ly/2kIM8Kz" />
<meta property="og:description" content="A busy woman of many jobs, Karen Mykietka admits that she spends too much time in front of a computer. In the past 20 years, she has lived in the north central Edmonton communities of Eastwood, Alb…" />
<meta property="article:published_time" content="2017-02-08T21:37:09+00:00" />
<meta property="article:modified_time" content="2017-02-08T21:37:09+00:00" />
<meta property="og:site_name" content="mediamag blog" />
<meta property="og:image" content="http://mediamag.ca/wp-content/uploads/2016/10/Constance125.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@mediamagdotca" />
<meta property="bitly:url" content="http://bit.ly/2kIM8Kz" /> 
	<style type="text/css">
		<!--
a, ul.menu li .separator {color:;}#rt-logo {background: url(http://mediamag.ca/wp-content/uploads/2016/12/magca_logo-250.png) 50% 0 no-repeat !important;}
#rt-logo {width: 250px;height: 250px;}
#rt-bg-image {background: url(http://mediamag.ca/wp-content/uploads/2017/01/blog-CBC-newsroom.jpg) 50% 0 no-repeat;}
#rt-bg-image {position: absolute;max-width: 100%;width: 1250px;height: 300px;top: 0;}
@media screen and (max-width: 780px) {
.blog .post-content{display: none;}
}

.rt-footer-bg2 #rt-bottom, .rt-footer-bg2 #rt-footer {
    display: none;
}

		-->
	</style>
	<script type="text/javascript">//<![CDATA[
window.addEvent('domready', function() {
				var switcher = document.id('gantry-viewswitcher');
				if (switcher) {
					switcher.addEvent('click', function(e) {
						e.stop();
						if ('0' == '0') document.id('gantry-viewswitcher').addClass('off');
						else $('gantry-viewswitcher').removeClass('off');
						Cookie.write('cerulean-unknown-switcher', '0');
						window.location.reload();
					});
				}
		
});	//]]></script>
</head>
<body  class="post-template-default single single-post postid-12055 single-format-standard logo-type-custom main-bg-bluered main-accent2-redcolor font-family-cerulean font-size-is-default layout-mode-responsive col12">
	<div class="rt-bg"><div class="rt-bg2">
		<div class="rt-top-section rt-dark">
			<div class="rt-container">
			    			    <header id="rt-top-surround">
										<div id="rt-top" >
						<div class="rt-container">
							
		
																						
		
				<div class="rt-grid-12 rt-alpha rt-omega">
					<div id="gantry_logo-2" class="widget widget_gantry_logo rt-block logo-block">
			<a href="http://mediamag.ca" id="rt-logo"></a>
		</div>
		</div>							<div class="clear"></div>
						</div>
					</div>
															<div id="rt-bg-image">
					</div>
																								</header>
				
				<div class="clear"></div>
			</div>
		</div>
				<div id="rt-transition">
			<div class="rt-container main-surround">
								<div class="rt-body-straight"><div class="left-top-pointer"></div><div class="right-top-pointer"></div></div>
								<div id="rt-mainbody-surround">
					<div class="gf-menu-device-container"></div>
					<div class="rt-container">
																																							    					<div id="rt-main" class="mb8-sa4">
			<div class="rt-grid-8">
	
								<div id="rt-content-top">
					
		
																						
		
				<div class="rt-grid-8 rt-alpha rt-omega">
					<div id="text-39" class="widget widget_text box3 rt-block">
			<div class="module-surround">
							<div class="module-title">
					<h2 class="title">
					Alberta media news, events, awards &#038; personalities					</h2>
				</div>
								<div class="module-content">
							<div class="textwidget"></div>
						</div>
					
			</div>
						<div class="rt-box3-btm"></div>
					</div>
		</div>				</div>
										
								<div class="rt-block">
					<div id="rt-mainbody">
						<div class="component-content">
							

	<div class="item-page">
		
		
			
						
			
			
				
								
			<div class="post-12055 post type-post status-publish format-standard hentry category-alberta-media-personalities" id="post-12055">

				
				
					<h2>
													<a href="http://bit.ly/2kIM8Kz" title="Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton">Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton</a>
											</h2>

				
				
				
								
					<dl class="article-info">

													
						
							
						
						
						
						
						
							<dd class="create"> Wednesday, 08 February 2017 14:37</dd>

						
						
						
						
						
											
						
						
						
						
						
					</dl>
				
				
				
							
				
										
				
				<div class="post-content">
						
					
<div class="juiz_sps_links  counters_both juiz_sps_displayed_both">
<p class="screen-reader-text juiz_sps_maybe_hidden_text">Share the post "Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton"</p>

	<ul class="juiz_sps_links_list juiz_sps_hide_name"><li class="juiz_sps_item juiz_sps_link_facebook"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2kIM8Kz"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2kIM8Kz', 'Facebook');" rel="nofollow" target="_blank" title="Share this article on Facebook"><span class="juiz_sps_icon jsps-facebook"></span><span class="juiz_sps_network_name">Facebook</span></a></li><li class="juiz_sps_item juiz_sps_link_twitter"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://twitter.com/intent/tweet?source=webclient&amp;original_referer=http://bit.ly/2kIM8Kz&amp;text=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz&amp;related=mediamagdotca&amp;via=mediamagdotca"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://twitter.com/intent/tweet?source=webclient&amp;original_referer=http://bit.ly/2kIM8Kz&amp;text=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz&amp;related=mediamagdotca&amp;via=mediamagdotca', 'Twitter');" rel="nofollow" target="_blank" title="Share this article on Twitter"><span class="juiz_sps_icon jsps-twitter"></span><span class="juiz_sps_network_name">Twitter</span></a></li><li class="juiz_sps_item juiz_sps_link_google"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://plus.google.com/share?url=http://bit.ly/2kIM8Kz"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://plus.google.com/share?url=http://bit.ly/2kIM8Kz', 'Google+');" rel="nofollow" target="_blank" title="Share this article on Google+"><span class="juiz_sps_icon jsps-google"></span><span class="juiz_sps_network_name">Google+</span></a></li><li class="juiz_sps_item juiz_sps_link_pinterest"><a href="javascript:void((function(){var%20e=document.createElement(&#039;script&#039;);e.setAttribute(&#039;type&#039;,&#039;text/javascript&#039;);e.setAttribute(&#039;charset&#039;,&#039;UTF-8&#039;);e.setAttribute(&#039;src&#039;,&#039;//assets.pinterest.com/js/pinmarklet.js?r=&#039;+Math.random()*99999999);document.body.appendChild(e)})());" rel="nofollow" title="Share an image of this article on Pinterest"><span class="juiz_sps_icon jsps-pinterest"></span><span class="juiz_sps_network_name">Pinterest</span></a></li><li class="juiz_sps_item juiz_sps_link_linkedin"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=JuizSocialPostSharer&amp;title=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=JuizSocialPostSharer&amp;title=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz', 'LinkedIn');" rel="nofollow" target="_blank" title="Share this article on LinkedIn"><span class="juiz_sps_icon jsps-linkedin"></span><span class="juiz_sps_network_name">LinkedIn</span></a></li><li class="juiz_sps_item juiz_sps_link_mail"><a href="mailto:?subject=Visit this link find on http://mediamag.ca&amp;body=Hi, I found this information for you : &quot;Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton&quot;! This is the direct link: http://bit.ly/2kIM8Kz Have a nice day :)" rel="nofollow" target="_blank" title="Share this article with a friend (email)"><span class="juiz_sps_icon jsps-mail"></span><span class="juiz_sps_network_name">E-mail</span></a></li></ul>
	</div>

<p><a href="http://mediamag.ca/2017/02/08/alberta-media-personality-karen-mykietka-publisher-of-rat-creek-press-community-builder-in-edmonton/karen-mykietka/" rel="attachment wp-att-12056"><img class="alignleft size-full wp-image-12056" src="http://mediamag.ca/wp-content/uploads/2017/02/Karen-Mykietka.jpg" alt="Karen-Mykietka" width="150" height="150" /></a>A busy woman of many jobs, Karen Mykietka admits that she spends too much time in front of a computer. In the past 20 years, she has lived in the north central Edmonton communities of Eastwood, Alberta Avenue, and now Parkdale, meeting “awesome people everywhere I go.” First as a volunteer for the Rat Creek Press in 2004 and shortly after that as the Publisher, she is a natural born organizer and leader who has a passionate commitment to community. <span id="more-12055"></span></p>
<h3><strong>From the Desk of Karen Mykietka</strong></h3>
<h4><strong> </strong><strong>When people think of “publisher” they may only think of getting the finances to bring out a newspaper. You do much more. </strong></h4>
<p><strong> </strong>As publisher the entire operation of the Rat Creek Press newspaper, my responsibilities include everything from budgeting, fund development, hiring, advertising, content, and community relations. We cover the news in the seven neighborhoods of Alberta Avenue, Delton, Eastwood, Elmwood Park, Parkdale-Cromdale, Spruce Avenue, and Westwood.</p>
<p>I’ve lived in the area almost 20 years and have been active in leagues, festivals and revitalization. I created this newspaper out of a newsletter over 10 years ago. Because of this history, I tend to be the most in touch with what’s happening in the community. I’m heavily involved in generating story ideas and community projects.</p>
<p>When you’re in the top job, you’re ultimately responsible for getting a newspaper into people’s mailboxes each month. You do whatever needs doing. I’ve done it all—writing, photography, advertising, ad design, delivery, book keeping, community events, consulting.</p>
<h4><strong>What does the community mean to you?</strong></h4>
<p>Community means getting involved. Without involvement, it’s just a bunch of houses and businesses. I must say our community is alive and full of activities, friendly and welcoming to all. I am deeply proud to be involved. I love the people, the stories, and the issues that make up our seven neighborhoods.</p>
<h4><strong>What is the purpose of a community newspaper?</strong></h4>
<p>While a newspaper’s purpose is obviously to communicate and inform, a community effort has the potential of going beyond mere one-way communication. The larger purpose is to help develop community. We also provide the opportunity for people to explore their creative side, to try a hand at writing and other journalistic skills.</p>
<h4><strong>A community newspaper may seem to be an anachronism in the era of social media. What do you think? </strong></h4>
<p>With journalism and communication being pushed online more and more, community newspapers are even more important. Social media and online don’t work for many groups, especially the more vulnerable–seniors, immigrants, low-income. Social media is good at connecting people over a larger geography. I think a free community paper delivered to every household in a small area gives everyone equal opportunity to learn about and get involved in their neighborhood.</p>
<h4><strong>How did you get involved?</strong></h4>
<p>In August 2004, I volunteered to look over the then-new newspaper’s financial books and bring them up-to-date as no one had been taking responsibility for them. I discovered the paper was in financial crisis and called a partner meeting. In September 2004, I took on the task of bringing new life to the paper.</p>
<p>The Rat Creek takes up hundreds of hours of my life but the paper was keeping me up at night long before I volunteered to work on it. Every month when I got my issue, my mind would spin with ideas and possibilities, with vision and hope for a community paper. Finally, I succumbed and decided to try making some of my grand visions reality.</p>
<p>I left the September 2004 partner’s meeting and was a little freaked out that I had to somehow get a paper produced and distributed in three weeks and I was starting from scratch with nothing. I put the word out and slowly found volunteers to help with design and editing skills.</p>
<p>We pulled off producing our first issue but unfortunately encountered major distribution problems and many homes did not received the paper into which we put many hours of labour!</p>
<p>I am happy to say we now publish 12,500 copies of a 16 page full-color paper every month.</p>
<h4><strong>What inspires you?</strong></h4>
<p>Twelve years ago, when I first received the Rat Creek Press newsletter in my mailbox, I could see the potential of what it could be. It felt like I was being “chased by a vision.” I had no background in journalism, no knowledge of the printing industry, and no one to show me the way. But I leaped in anyway and with my eye on the vision I plugged away day-by-day.</p>
<p>Thankfully, I not only had vision but persistence and commitment and a great partner – Dawn Freeman. Dawn worked side by side with me at the beginning to make the paper what it is today.</p>
<p>My day to day person is now editor Talea Medynski. Talea is committed and creative, tough and resilient.</p>
<p>These are the qualities needed by individuals who are drawn to the daily grind of producing a community newspaper with very little cash.</p>
<p>We’ve had dozens and dozens of people participate in the <em>Rat Creek Press</em> in one form or another over the years. It truly is a newspaper for the community by the community.</p>
<p>In the early years, I enjoyed learning to write all kinds of articles. I loved having a reason to be nosy and ask questions. I met many interesting people and made new friends.</p>
<p>In every issue, you are constantly thinking of ways to survive and thrive as a community newspaper.</p>
<p>Money and people power are two important and interrelated factors when it comes to survival. The paper has survived because people have been committed to it regardless of whether they were compensated for their time and skills. Today, our staff of three, myself and editor, Talea Medynski and designer Lorraine Shulba are paid a modest monthly contract fee. We rely heavily on over 30 different volunteer contributors and are happy we were able to start giving them a small honorarium.</p>
<p>Thriving on the other hand is more about being in touch with and connected to the community. From the start, I was trying to build a community newspaper for the community by the community. In 2005, only three of the seven community leagues contributed. Just this past year, we finally got all seven involved.</p>
<p>We are incorporated as a non-profit society. This provides the Rat Creek Press with a more formal structure and the opportunity to recruit board members from across the community. It also enables us to apply to do a casino and for a variety of grants.</p>
<h4><strong>What are some of your proudest accomplishments?</strong></h4>
<p><strong> </strong>Most recently, my pride and joy has been getting our website up and running. Articles from the editions are posted and shareable.</p>
<p>Another major accomplishment was our eight page pull out feature on Shared Housing in November which put that issue to 24 pages!</p>
<p>The Rat Creek spearheaded a fantastic history project in 2011 which culminated in a theatre performance by local actors based on interviews with residents and seniors connected to the area. In 2012, we received honorable mention for the Governor General’s History Award in Community Programming for this project.</p>
<p>I’m proud of the great writing of our contributors from profiles to features to editorials. Our paper is such an interesting and great read every month. We cover sensitive and touchy topics in a respectful, uplifting way focusing on solutions or calls to action, not sensationalism. All communities have issues and they all have strengths and hidden gems. We show off the greatness of our community while still acknowledging the issues.</p>
<p>The newspaper, and also our new website are informative and attractive. They provide a “good read” about people, businesses, interests, developments and challenges in the area.</p>
<p>Yes, the paper flourishes, and looks inviting and professional. Our new website finally has the ability to post and share articles individually which is important in today’s social media world. You can find our mission and goals, advertising information, contributors as well as all our back issues and a community calendar.</p>
<p><strong>What are the goals of <em>Rat Creek Press</em>?</strong></p>
<p>Our three goals are to build community, encourage communication, and increase capacity while growing a dynamic and vibrant community newspaper.</p>
<p>I am proud to say we have committed advertisers, and are always reaching out to new ones in the community. The paper is financially viable and self-sustaining in terms of production costs. I’m glad we now have a small paid staff. It’s not reasonable to ask volunteers to continue putting in the number of hours that are required to produce the paper.</p>
<p>We are working on building up a strong and diversely skilled board who can guide the future of the paper, who develop funding sources, and who help Rat Creek Press continue to meet its three goals. Right now we are focusing on volunteer development and creating deeper connections with the neighborhoods we serve.</p>
<h4><strong>What are the ingredients of success?</strong></h4>
<p>Good relationships. Everything depends on good relationships—an effective production team, a functional board, happy advertisers, willing financial supporters, and giving volunteers.</p>
<h4><strong>What are your professional challenges as publisher?</strong></h4>
<p>What I can’t find someone else to do, I have to do myself.</p>
<p>Soliciting advertising is time-consuming work, with sometimes little pay off in terms of paid ads. We’ve had a number of ad reps over the years but the job always seems to end up back on my plate.</p>
<p>In our early years, finding, coordinating, and keeping more than 70-plus volunteer carriers was a never-ending job which is why we moved to Canada Post delivery. The financial cost of this is significant. Sometimes it’s a threat to staying in the black but it is effective.</p>
<h4><strong>What are your challenges as a person?</strong></h4>
<p>I live, work and play in the same community. In most ways, it’s awesome. I love the opportunity to meet many interesting people, develop deeper relationships, and really get to know my community. On the downside, it’s almost impossible to just live and enjoy and not go into work mode.</p>
<p>Everyone I meet, everything I do, everything I learn is a potential story! I can’t unplug from the community for any length of time. My job depends on knowing the community.</p>
<p><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/http://ratcreek.org"  onclick="__gaTracker('send', 'event', 'outbound-article', 'http://ratcreek.org', 'http://ratcreek.org');" target="_blank">http://ratcreek.org</a></p>
<p><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://www.facebook.com/RatCreekPress"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.facebook.com/RatCreekPress', 'https://www.facebook.com/RatCreekPress');" target="_blank">https://www.facebook.com/RatCreekPress</a></p>
<p><a href="http://mediamag.ca/2016/10/26/alberta-media-personality-janet-dirks-alberta-bureau-chief-ctv-national-news/accent-revised150/" rel="attachment wp-att-11835"><img class="alignnone wp-image-11835 size-full" src="http://mediamag.ca/wp-content/uploads/2016/10/accent-revised150.png" alt="accent-revised" width="150" height="33" /></a></p>
<p><strong>By Constance Brissenden for MediaMag.ca</strong></p>
<p><a href="http://mediamag.ca/2016/10/26/alberta-media-personality-janet-dirks-alberta-bureau-chief-ctv-national-news/rs-cpnnie-portrait-3/" rel="attachment wp-att-11833"><img class="alignleft size-full wp-image-11833" src="http://mediamag.ca/wp-content/uploads/2016/10/Constance125.jpg" alt="Constance Brissenden" width="125" height="125" /></a>Constance Brissenden’s writing, editing, and teaching career spans more than 40 years. A Masters graduate of the University of Alberta (Theatre), she is co-author of award-winning children&#8217;s books by Cree author Larry Loyie, as well as more than a dozen titles of history and travel. Website: <a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/http://www.firstnationswriter.com"  onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.firstnationswriter.com', 'www.firstnationswriter.com');" target="_blank">www.firstnationswriter.com</a>.</p>

<div class="juiz_sps_links  counters_both juiz_sps_displayed_both">
<p class="screen-reader-text juiz_sps_maybe_hidden_text">Share the post "Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton"</p>

	<ul class="juiz_sps_links_list juiz_sps_hide_name"><li class="juiz_sps_item juiz_sps_link_facebook"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2kIM8Kz"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2kIM8Kz', 'Facebook');" rel="nofollow" target="_blank" title="Share this article on Facebook"><span class="juiz_sps_icon jsps-facebook"></span><span class="juiz_sps_network_name">Facebook</span></a></li><li class="juiz_sps_item juiz_sps_link_twitter"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://twitter.com/intent/tweet?source=webclient&amp;original_referer=http://bit.ly/2kIM8Kz&amp;text=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz&amp;related=mediamagdotca&amp;via=mediamagdotca"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://twitter.com/intent/tweet?source=webclient&amp;original_referer=http://bit.ly/2kIM8Kz&amp;text=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz&amp;related=mediamagdotca&amp;via=mediamagdotca', 'Twitter');" rel="nofollow" target="_blank" title="Share this article on Twitter"><span class="juiz_sps_icon jsps-twitter"></span><span class="juiz_sps_network_name">Twitter</span></a></li><li class="juiz_sps_item juiz_sps_link_google"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://plus.google.com/share?url=http://bit.ly/2kIM8Kz"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://plus.google.com/share?url=http://bit.ly/2kIM8Kz', 'Google+');" rel="nofollow" target="_blank" title="Share this article on Google+"><span class="juiz_sps_icon jsps-google"></span><span class="juiz_sps_network_name">Google+</span></a></li><li class="juiz_sps_item juiz_sps_link_pinterest"><a href="javascript:void((function(){var%20e=document.createElement(&#039;script&#039;);e.setAttribute(&#039;type&#039;,&#039;text/javascript&#039;);e.setAttribute(&#039;charset&#039;,&#039;UTF-8&#039;);e.setAttribute(&#039;src&#039;,&#039;//assets.pinterest.com/js/pinmarklet.js?r=&#039;+Math.random()*99999999);document.body.appendChild(e)})());" rel="nofollow" title="Share an image of this article on Pinterest"><span class="juiz_sps_icon jsps-pinterest"></span><span class="juiz_sps_network_name">Pinterest</span></a></li><li class="juiz_sps_item juiz_sps_link_linkedin"><a target="_blank" rel="nofollow" href="http://mediamag.ca/goto/https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=JuizSocialPostSharer&amp;title=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz"  onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=JuizSocialPostSharer&amp;title=Alberta%20Media%20Personality%3A%20Karen%20Mykietka%2C%20Publisher%20of%20Rat%20Creek%20Press%20%26%20Community%20Builder%20in%20Edmonton&amp;url=http://bit.ly/2kIM8Kz', 'LinkedIn');" rel="nofollow" target="_blank" title="Share this article on LinkedIn"><span class="juiz_sps_icon jsps-linkedin"></span><span class="juiz_sps_network_name">LinkedIn</span></a></li><li class="juiz_sps_item juiz_sps_link_mail"><a href="mailto:?subject=Visit this link find on http://mediamag.ca&amp;body=Hi, I found this information for you : &quot;Alberta Media Personality: Karen Mykietka, Publisher of Rat Creek Press &#038; Community Builder in Edmonton&quot;! This is the direct link: http://bit.ly/2kIM8Kz Have a nice day :)" rel="nofollow" target="_blank" title="Share this article with a friend (email)"><span class="juiz_sps_icon jsps-mail"></span><span class="juiz_sps_network_name">E-mail</span></a></li></ul>
	</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-12055" class="share-facebook sd-button share-icon" href="http://mediamag.ca/2017/02/08/alberta-media-personality-karen-mykietka-publisher-of-rat-creek-press-community-builder-in-edmonton/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-12055" class="share-linkedin sd-button share-icon" href="http://mediamag.ca/2017/02/08/alberta-media-personality-karen-mykietka-publisher-of-rat-creek-press-community-builder-in-edmonton/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-12055" class="share-twitter sd-button share-icon" href="http://mediamag.ca/2017/02/08/alberta-media-personality-karen-mykietka-publisher-of-rat-creek-press-community-builder-in-edmonton/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>
				</div>
				
				
				
								
				
								
				
				
									
				
				
			</div>
			
						
					
		
	</div>						</div>
					</div>
				</div>
					
								<div id="rt-content-bottom">
					
		
																						
		
				<div class="rt-grid-8 rt-alpha rt-omega">
					<div id="tag_cloud-5" class="widget widget_tag_cloud box5 nomarginall rt-block">
			<div class="module-surround">
							<div class="module-content">
								<div class="module-title">
					<h2 class="title">
					Tags					</h2>
				</div>
				<div class="tagcloud"><a href='http://mediamag.ca/tag/alberta/' class='tag-link-42 tag-link-position-1' title='7 topics' style='font-size: 14.6141732283pt;'>Alberta</a>
<a href='http://mediamag.ca/tag/amaas/' class='tag-link-38 tag-link-position-2' title='1 topic' style='font-size: 8pt;'>AMAAS</a>
<a href='http://mediamag.ca/tag/ampa/' class='tag-link-31 tag-link-position-3' title='2 topics' style='font-size: 9.9842519685pt;'>AMPA</a>
<a href='http://mediamag.ca/tag/arts-awards/' class='tag-link-41 tag-link-position-4' title='1 topic' style='font-size: 8pt;'>Arts Awards</a>
<a href='http://mediamag.ca/tag/astral/' class='tag-link-55 tag-link-position-5' title='2 topics' style='font-size: 9.9842519685pt;'>Astral</a>
<a href='http://mediamag.ca/tag/astral-media/' class='tag-link-25 tag-link-position-6' title='4 topics' style='font-size: 12.4094488189pt;'>Astral Media</a>
<a href='http://mediamag.ca/tag/bill-bourne/' class='tag-link-21 tag-link-position-7' title='1 topic' style='font-size: 8pt;'>Bill Bourne</a>
<a href='http://mediamag.ca/tag/book-tv/' class='tag-link-62 tag-link-position-8' title='1 topic' style='font-size: 8pt;'>Book TV</a>
<a href='http://mediamag.ca/tag/calgary/' class='tag-link-27 tag-link-position-9' title='30 topics' style='font-size: 21.1181102362pt;'>Calgary</a>
<a href='http://mediamag.ca/tag/canadian-authors-association/' class='tag-link-28 tag-link-position-10' title='1 topic' style='font-size: 8pt;'>Canadian Authors Association</a>
<a href='http://mediamag.ca/tag/cfit/' class='tag-link-50 tag-link-position-11' title='2 topics' style='font-size: 9.9842519685pt;'>CFIT</a>
<a href='http://mediamag.ca/tag/cfmg/' class='tag-link-23 tag-link-position-12' title='2 topics' style='font-size: 9.9842519685pt;'>CFMG</a>
<a href='http://mediamag.ca/tag/cibk/' class='tag-link-24 tag-link-position-13' title='1 topic' style='font-size: 8pt;'>CIBK</a>
<a href='http://mediamag.ca/tag/citytv/' class='tag-link-52 tag-link-position-14' title='3 topics' style='font-size: 11.3070866142pt;'>Citytv</a>
<a href='http://mediamag.ca/tag/ckua/' class='tag-link-54 tag-link-position-15' title='8 topics' style='font-size: 15.1653543307pt;'>CKUA</a>
<a href='http://mediamag.ca/tag/cprs/' class='tag-link-39 tag-link-position-16' title='2 topics' style='font-size: 9.9842519685pt;'>CPRS</a>
<a href='http://mediamag.ca/tag/ctv/' class='tag-link-45 tag-link-position-17' title='11 topics' style='font-size: 16.5984251969pt;'>CTV</a>
<a href='http://mediamag.ca/tag/ctvglobemedia/' class='tag-link-53 tag-link-position-18' title='1 topic' style='font-size: 8pt;'>CTVglobemedia</a>
<a href='http://mediamag.ca/tag/edmonton/' class='tag-link-30 tag-link-position-19' title='36 topics' style='font-size: 22pt;'>Edmonton</a>
<a href='http://mediamag.ca/tag/events/' class='tag-link-37 tag-link-position-20' title='1 topic' style='font-size: 8pt;'>Events</a>
<a href='http://mediamag.ca/tag/festivals/' class='tag-link-33 tag-link-position-21' title='3 topics' style='font-size: 11.3070866142pt;'>Festivals</a>
<a href='http://mediamag.ca/tag/gayleen-froese/' class='tag-link-61 tag-link-position-22' title='1 topic' style='font-size: 8pt;'>Gayleen Froese</a>
<a href='http://mediamag.ca/tag/genie-awards/' class='tag-link-57 tag-link-position-23' title='1 topic' style='font-size: 8pt;'>Genie Awards</a>
<a href='http://mediamag.ca/tag/global-tv/' class='tag-link-59 tag-link-position-24' title='2 topics' style='font-size: 9.9842519685pt;'>Global TV</a>
<a href='http://mediamag.ca/tag/golden-west/' class='tag-link-49 tag-link-position-25' title='2 topics' style='font-size: 9.9842519685pt;'>Golden West</a>
<a href='http://mediamag.ca/tag/iabc/' class='tag-link-26 tag-link-position-26' title='2 topics' style='font-size: 9.9842519685pt;'>IABC</a>
<a href='http://mediamag.ca/tag/kelley-keehn/' class='tag-link-63 tag-link-position-27' title='1 topic' style='font-size: 8pt;'>Kelley Keehn</a>
<a href='http://mediamag.ca/tag/magazines/' class='tag-link-32 tag-link-position-28' title='4 topics' style='font-size: 12.4094488189pt;'>Magazines</a>
<a href='http://mediamag.ca/tag/media-training/' class='tag-link-43 tag-link-position-29' title='4 topics' style='font-size: 12.4094488189pt;'>Media Training</a>
<a href='http://mediamag.ca/tag/mobile/' class='tag-link-47 tag-link-position-30' title='2 topics' style='font-size: 9.9842519685pt;'>Mobile</a>
<a href='http://mediamag.ca/tag/mom-magazine/' class='tag-link-56 tag-link-position-31' title='1 topic' style='font-size: 8pt;'>Mom Magazine</a>
<a href='http://mediamag.ca/tag/myron-hyrak/' class='tag-link-58 tag-link-position-32' title='1 topic' style='font-size: 8pt;'>Myron Hyrak</a>
<a href='http://mediamag.ca/tag/pace/' class='tag-link-36 tag-link-position-33' title='1 topic' style='font-size: 8pt;'>PACE</a>
<a href='http://mediamag.ca/tag/pattison/' class='tag-link-65 tag-link-position-34' title='1 topic' style='font-size: 8pt;'>Pattison</a>
<a href='http://mediamag.ca/tag/poetry/' class='tag-link-34 tag-link-position-35' title='1 topic' style='font-size: 8pt;'>Poetry</a>
<a href='http://mediamag.ca/tag/publishing/' class='tag-link-64 tag-link-position-36' title='1 topic' style='font-size: 8pt;'>Publishing</a>
<a href='http://mediamag.ca/tag/shaw/' class='tag-link-48 tag-link-position-37' title='4 topics' style='font-size: 12.4094488189pt;'>Shaw</a>
<a href='http://mediamag.ca/tag/smartphones/' class='tag-link-46 tag-link-position-38' title='1 topic' style='font-size: 8pt;'>Smartphones</a>
<a href='http://mediamag.ca/tag/sports/' class='tag-link-51 tag-link-position-39' title='2 topics' style='font-size: 9.9842519685pt;'>Sports</a>
<a href='http://mediamag.ca/tag/st-albert/' class='tag-link-40 tag-link-position-40' title='2 topics' style='font-size: 9.9842519685pt;'>St. Albert</a>
<a href='http://mediamag.ca/tag/timothy-taylor/' class='tag-link-29 tag-link-position-41' title='1 topic' style='font-size: 8pt;'>Timothy Taylor</a>
<a href='http://mediamag.ca/tag/tim-spelliscy/' class='tag-link-60 tag-link-position-42' title='1 topic' style='font-size: 8pt;'>Tim Spelliscy</a>
<a href='http://mediamag.ca/tag/virgin-radio/' class='tag-link-22 tag-link-position-43' title='3 topics' style='font-size: 11.3070866142pt;'>Virgin Radio</a>
<a href='http://mediamag.ca/tag/volunteering/' class='tag-link-35 tag-link-position-44' title='2 topics' style='font-size: 9.9842519685pt;'>Volunteering</a>
<a href='http://mediamag.ca/tag/youth/' class='tag-link-18 tag-link-position-45' title='2 topics' style='font-size: 9.9842519685pt;'>youth</a></div>
				</div>
					
			</div>
					</div>
		
		
																						
		
				<div id="text-22" class="widget widget_text box2 rounded nomarginall rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><img src="http://mediamag.ca/wp-content/uploads/2013/09/marilyn100.jpg" alt="Marilyn Jones, Edmonton, Alberta" align="left" hspace="10"><strong> ABOUT ME</strong><br />I am Marilyn Jones, a news junkie with a penchant for publishing, politics, communications, gardening, hiking, reading, the arts and training nonprofit organizations in media relations and social media communications in Alberta (BA in English with Honours, U of A; Master of Publishing, SFU)</div>
						</div>
					
			</div>
					</div>
		</div>				</div>
									
			</div>        
			
		
																						
		
				<div class="rt-grid-4 ">
		<div id="rt-sidebar-a">
					<div id="social-widget-2" class="widget Social_Widget box4 nopaddingright rt-block">
			<div class="module-surround">
							<div class="module-content">
				<div class="socialmedia-buttons smw_left"><div class="socialmedia-text">connect with me</div><a href="https://twitter.com/mediamagdotca" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/twitter.png" 
				alt="Connect with me Twitter" 
				title="Connect with me Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.linkedin.com/in/marilynjones " rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/linkedin.png" 
				alt="Connect with me LinkedIn" 
				title="Connect with me LinkedIn" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.flickr.com/photos/mediamagca/sets/" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/flickr.png" 
				alt="Connect with me Flickr" 
				title="Connect with me Flickr" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.pinterest.com/mediamagdotca/boards/" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/pinterest.png" 
				alt="Connect with me Pinterest" 
				title="Connect with me Pinterest" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.youtube.com/user/mediamag " rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/youtube.png" 
				alt="Connect with me YouTube" 
				title="Connect with me YouTube" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://www.facebook.com/mediamag.ca" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/facebook.png" 
				alt="Connect with me Facebook" 
				title="Connect with me Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.mediamag.ca" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/wordpress.png" 
				alt="Connect with me Wordpress" 
				title="Connect with me Wordpress" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="mailto:marilyn@mediamag.ca" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/plugins/social-media-widget/images/default/32/email.png" 
				alt="Connect with me E-mail" 
				title="Connect with me E-mail" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.linkedin.com/company/corporate-&-social-media-consultant-at-rivercity-productions" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/uploads/2013/09/LinkedINcompany.jpg" 
				alt="Connect with me LinkedIn Company Page" 
				title="Connect with me LinkedIn Company Page" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://mediamag.ca/contact-marilyn-jones/" rel="nofollow" target="_blank"><img width="24" height="24" src="http://mediamag.ca/wp-content/uploads/2013/09/Email.png" 
				alt="Connect with me email me" 
				title="Connect with me email me" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a></div>				</div>
					
			</div>
					</div>
		
		
																						
		
				<div id="text-40" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><a href="https://twitter.com/mediamagdotca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://twitter.com/mediamagdotca', 'Tweets by @mediamagdotca');" class="twitter-timeline"  data-widget-id="689525470908387328">Tweets by @mediamagdotca</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
						</div>
					
			</div>
					</div>
		
		
																						
		
				<div id="gantry_categories-2" class="widget widget_gantry_categories box4 rounded uppercase rt-block">
			<div class="module-surround">
							<div class="module-title">
					<h2 class="title">
					Categories					</h2>
				</div>
								<div class="module-content">
				
			<ul class="menu">

					<li class="cat-item cat-item-13"><a href="http://mediamag.ca/category/alberta-media-news/" title="desc"><span>Alberta media news</span></a>
</li>
	<li class="cat-item cat-item-14"><a href="http://mediamag.ca/category/alberta-media-events/" title="desc"><span>Alberta media events</span></a>
</li>
	<li class="cat-item cat-item-16"><a href="http://mediamag.ca/category/alberta-media-awards/" title="desc"><span>Alberta media awards</span></a>
</li>
	<li class="cat-item cat-item-15"><a href="http://mediamag.ca/category/alberta-media-moves/" title="desc"><span>Alberta media moves</span></a>
</li>
	<li class="cat-item cat-item-17"><a href="http://mediamag.ca/category/alberta-media-personalities/" title="desc"><span>Alberta media personalities</span></a>
</li>
	<li class="cat-item cat-item-10"><a href="http://mediamag.ca/category/alberta-books-publishing/" title="desc"><span>Alberta books &amp; publishing</span></a>
</li>
	<li class="cat-item cat-item-11"><a href="http://mediamag.ca/category/alberta-films-tv-video/" title="desc"><span>Alberta film/television/video</span></a>
</li>
	<li class="cat-item cat-item-125"><a href="http://mediamag.ca/category/alberta-websites/" ><span>Alberta websites</span></a>
</li>
	<li class="cat-item cat-item-186"><a href="http://mediamag.ca/category/alberta-blogs/" ><span>Alberta blogs</span></a>
</li>
	<li class="cat-item cat-item-254"><a href="http://mediamag.ca/category/alberta-podcasts/" ><span>Alberta podcasts</span></a>
</li>
	<li class="cat-item cat-item-44"><a href="http://mediamag.ca/category/digital-social-media/" ><span>Digital/Social Media</span></a>
</li>
	<li class="cat-item cat-item-8"><a href="http://mediamag.ca/category/magazines-in-alberta/" title="desc"><span>Magazines in Alberta</span></a>
</li>
	<li class="cat-item cat-item-7"><a href="http://mediamag.ca/category/newspapers-in-alberta/" title="desc"><span>Newspapers in Alberta</span></a>
</li>
	<li class="cat-item cat-item-5"><a href="http://mediamag.ca/category/radio-stations-in-alberta/" title="Radio stations in Alberta description goes here. "><span>Radio Stations in Alberta</span></a>
</li>
	<li class="cat-item cat-item-6"><a href="http://mediamag.ca/category/television-stations-in-alberta/" title="desc"><span>Television Stations in Alberta</span></a>
</li>
	<li class="cat-item cat-item-106"><a href="http://mediamag.ca/category/alberta-media-training/" title="desc"><span>Media Training in Alberta</span></a>
</li>
	<li class="cat-item cat-item-1"><a href="http://mediamag.ca/category/uncategorized/" ><span>Uncategorized</span></a>
</li>

			</ul>

						</div>
					
			</div>
					</div>
		
		
																						
		
				<div id="gantry_archives-2" class="widget widget_gantry_archives box4 uppercase rt-block">
			<div class="module-surround">
							<div class="module-title">
					<h2 class="title">
					Archives					</h2>
				</div>
								<div class="module-content">
							<select name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
				<option value="">Select Date</option> 	<option value='http://mediamag.ca/2017/02/'> February 2017 </option>
	<option value='http://mediamag.ca/2017/01/'> January 2017 </option>
	<option value='http://mediamag.ca/2016/12/'> December 2016 </option>
	<option value='http://mediamag.ca/2016/11/'> November 2016 </option>
	<option value='http://mediamag.ca/2016/10/'> October 2016 </option>
	<option value='http://mediamag.ca/2016/09/'> September 2016 </option>
	<option value='http://mediamag.ca/2016/08/'> August 2016 </option>
	<option value='http://mediamag.ca/2016/07/'> July 2016 </option>
	<option value='http://mediamag.ca/2016/06/'> June 2016 </option>
	<option value='http://mediamag.ca/2016/05/'> May 2016 </option>
	<option value='http://mediamag.ca/2016/04/'> April 2016 </option>
	<option value='http://mediamag.ca/2016/03/'> March 2016 </option>
	<option value='http://mediamag.ca/2016/02/'> February 2016 </option>
	<option value='http://mediamag.ca/2016/01/'> January 2016 </option>
	<option value='http://mediamag.ca/2015/12/'> December 2015 </option>
	<option value='http://mediamag.ca/2015/11/'> November 2015 </option>
	<option value='http://mediamag.ca/2015/10/'> October 2015 </option>
	<option value='http://mediamag.ca/2015/07/'> July 2015 </option>
	<option value='http://mediamag.ca/2015/06/'> June 2015 </option>
	<option value='http://mediamag.ca/2015/05/'> May 2015 </option>
	<option value='http://mediamag.ca/2015/04/'> April 2015 </option>
	<option value='http://mediamag.ca/2015/03/'> March 2015 </option>
	<option value='http://mediamag.ca/2015/02/'> February 2015 </option>
	<option value='http://mediamag.ca/2015/01/'> January 2015 </option>
	<option value='http://mediamag.ca/2014/11/'> November 2014 </option>
	<option value='http://mediamag.ca/2014/10/'> October 2014 </option>
	<option value='http://mediamag.ca/2014/09/'> September 2014 </option>
	<option value='http://mediamag.ca/2014/08/'> August 2014 </option>
	<option value='http://mediamag.ca/2014/07/'> July 2014 </option>
	<option value='http://mediamag.ca/2014/06/'> June 2014 </option>
	<option value='http://mediamag.ca/2014/05/'> May 2014 </option>
	<option value='http://mediamag.ca/2014/04/'> April 2014 </option>
	<option value='http://mediamag.ca/2014/03/'> March 2014 </option>
	<option value='http://mediamag.ca/2014/02/'> February 2014 </option>
	<option value='http://mediamag.ca/2014/01/'> January 2014 </option>
	<option value='http://mediamag.ca/2013/12/'> December 2013 </option>
	<option value='http://mediamag.ca/2013/11/'> November 2013 </option>
	<option value='http://mediamag.ca/2013/10/'> October 2013 </option>
	<option value='http://mediamag.ca/2013/09/'> September 2013 </option>
	<option value='http://mediamag.ca/2013/07/'> July 2013 </option>
	<option value='http://mediamag.ca/2013/06/'> June 2013 </option>
	<option value='http://mediamag.ca/2013/05/'> May 2013 </option>
	<option value='http://mediamag.ca/2013/04/'> April 2013 </option>
	<option value='http://mediamag.ca/2013/03/'> March 2013 </option>
	<option value='http://mediamag.ca/2013/02/'> February 2013 </option>
	<option value='http://mediamag.ca/2013/01/'> January 2013 </option>
	<option value='http://mediamag.ca/2012/11/'> November 2012 </option>
	<option value='http://mediamag.ca/2012/10/'> October 2012 </option>
	<option value='http://mediamag.ca/2012/09/'> September 2012 </option>
	<option value='http://mediamag.ca/2012/08/'> August 2012 </option>
	<option value='http://mediamag.ca/2012/07/'> July 2012 </option>
	<option value='http://mediamag.ca/2012/06/'> June 2012 </option>
	<option value='http://mediamag.ca/2012/05/'> May 2012 </option>
	<option value='http://mediamag.ca/2012/04/'> April 2012 </option>
	<option value='http://mediamag.ca/2012/03/'> March 2012 </option>
	<option value='http://mediamag.ca/2012/02/'> February 2012 </option>
	<option value='http://mediamag.ca/2012/01/'> January 2012 </option>
	<option value='http://mediamag.ca/2011/12/'> December 2011 </option>
	<option value='http://mediamag.ca/2011/11/'> November 2011 </option>
	<option value='http://mediamag.ca/2011/10/'> October 2011 </option>
	<option value='http://mediamag.ca/2011/09/'> September 2011 </option>
	<option value='http://mediamag.ca/2011/08/'> August 2011 </option>
	<option value='http://mediamag.ca/2011/07/'> July 2011 </option>
	<option value='http://mediamag.ca/2011/06/'> June 2011 </option>
	<option value='http://mediamag.ca/2011/05/'> May 2011 </option>
	<option value='http://mediamag.ca/2011/04/'> April 2011 </option>
	<option value='http://mediamag.ca/2011/03/'> March 2011 </option>
			</select>

						</div>
					
			</div>
					</div>
		
		
																						
		
				<div id="linkcat-4" class="widget widget_links box3 rounded lowercase rt-block">
			<div class="module-surround">
							<div class="module-content">
								<div class="module-title">
					<h2 class="title">
					Our other websites:					</h2>
				</div>
				
	<ul class='xoxo blogroll'>
<li><a href="http://www.mediainalberta.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.mediainalberta.ca', 'mediainalberta.ca');" rel="me" title="Alberta media directory &amp; media publicity services" target="_blank">mediainalberta.ca</a></li>
<li><a href="http://www.mediatraininginalberta.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.mediatraininginalberta.ca', 'mediatraininginalberta.ca');" rel="me" title="Media Training in Alberta" target="_blank">mediatraininginalberta.ca</a></li>
<li><a href="http://www.nonprofitnewsalberta.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.nonprofitnewsalberta.ca', 'nonprofitnewsalberta.ca');" title="Nonprofit news in Alberta">nonprofitnewsalberta.ca</a></li>
<li><a href="http://www.rivercityproductions.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.rivercityproductions.ca', 'RiverCityProductions.ca');" rel="me" title="&gt; publishers of mediamag.ca, mediainalberta.ca, mediatraininginalberta.ca &amp; nonprofitnewsalberta.ca " target="_blank">RiverCityProductions.ca</a></li>

	</ul>
				</div>
					
			</div>
						<div class="rt-box3-btm"></div>
					</div>
		</div></div>
			<div class="clear"></div>
		</div>
																								</div>
				</div>
				<div class="rt-body-btm"><div class="left-btm-pointer"></div><div class="right-btm-pointer"></div></div>
			</div>
		</div>
				<footer id="rt-footer-surround" class="rt-dark">
			<div class="rt-container">
			<div class="rt-footer-bg"><div class="rt-footer-bg2">
								<div id="rt-bottom">
					
		
																						
		
				<div class="rt-grid-12 rt-alpha rt-omega">
					<div id="text-35" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-title">
					<h2 class="title">
					Proud member of:					</h2>
				</div>
								<div class="module-content">
							<div class="textwidget"></div>
						</div>
					
			</div>
					</div>
		</div>					<div class="clear"></div>
				</div>
												<div id="rt-footer">
					
		
																						
		
				<div class="rt-grid-2 rt-alpha">
					<div id="text-30" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><img src="http://mediamag.ca/wp-content/uploads/2014/02/Digital-110.jpg"></div>
						</div>
					
			</div>
					</div>
		</div>
		
																						
		
		
		
																						
		
				<div class="rt-grid-2">
					<div id="text-36" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><p><img src="http://mediamag.ca/wp-content/uploads/2014/02/GetPublishing110.jpg"></p>
</div>
						</div>
					
			</div>
					</div>
		</div>
		
																						
		
		
		
																						
		
				<div class="rt-grid-2">
					<div id="text-29" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><img src="http://mediamag.ca/wp-content/uploads/2014/02/EAC.jpg"></div>
						</div>
					
			</div>
					</div>
		</div>
		
																						
		
		
		
																						
		
				<div class="rt-grid-2">
					<div id="text-31" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><img src="http://mediamag.ca/wp-content/uploads/2014/02/ECVO-110.jpg"></div>
						</div>
					
			</div>
					</div>
		</div>
		
																						
		
		
		
																						
		
				<div class="rt-grid-2">
					<div id="text-32" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><img src="http://mediamag.ca/wp-content/uploads/2014/02/AMPA110.jpg"></div>
						</div>
					
			</div>
					</div>
		</div>
		
																						
		
		
		
																						
		
				<div class="rt-grid-2 rt-omega">
					<div id="text-37" class="widget widget_text rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><img src="http://mediamag.ca/wp-content/uploads/2014/02/WGA110.jpg"></div>
						</div>
					
			</div>
					</div>
		</div>					<div class="clear"></div>
				</div>
												<div id="rt-copyright">
					
		
																						
		
				<div class="rt-grid-12 rt-alpha rt-omega">
					<div id="text-14" class="widget widget_text title3 rt-block">
			<div class="module-surround">
							<div class="module-content">
							<div class="textwidget"><div align="center"><img src="http://nonprofitnewsalberta.ca/wp-content/uploads/2015/04/accent-revised.png"><br /><br />

<img src="http://nonprofitnewsalberta.ca/wp-content/uploads/2015/04/aRCP_logo.png"><br>
  <br />

  <a href="http://www.rivercityproductions.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.rivercityproductions.ca', 'RiverCityProductions');">RiverCityProductions</a> | <a href="http://www.mediamag.ca">mediamag.ca</a> | <a href="http://www.mediainalberta.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.mediainalberta.ca', 'mediainalberta.ca \n  ');">mediainalberta.ca 
  </a>|<a href="http://www.mediatraininginalberta.ca" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.mediatraininginalberta.ca', 'mediatraininginalberta.ca');">mediatraininginalberta.ca</a> 
  | <a href="http://www.nonprofitnewsalberta.ca%20" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.nonprofitnewsalberta.ca%20', 'nonprofitnewsalberta.ca');">nonprofitnewsalberta.ca</a> 
<br />
125, 11215 Jasper Avenue, Edmonton, Alberta | T5K 0L5 | ph: 780-695-5675</div></div>
						</div>
					
			</div>
					</div>
		</div>					<div class="clear"></div>
				</div>
								<div class="clear"></div>
			</div></div>
			</div>
		</footer>
			</div></div>
				
		
				
		
				<div id="text-34" class="widget widget_text">
					<div class="textwidget"><script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-20534248-3']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script></div>
			
		</div>
				
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/mediamag.ca\/2017\/02\/08\/alberta-media-personality-karen-mykietka-publisher-of-rat-creek-press-community-builder-in-edmonton\/":12055};
	</script>
<script type='text/javascript' src='http://mediamag.ca/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='http://mediamag.ca/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mediamag.ca/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.4.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
	</body>
</html>
